At the Data Center, we use Cisco 3020’s as edge switches in a redundant way; 2 for front end network and 2 for back end network.
We also created EtherChannel trunks on each switches to uplink our ESX servers to our Cisco 6500 core switches.
The trunk is made of ports 17 to 20, that gives us a trunk of 4Gb per switch. We can eventually double that bandwidth by adding port 21 to 24.
Now looking at the ESX network configuration, depending of the trunk type you use at the physical switch layer, you configure the vSwitch accordingly.
In our case we use the Active/Active with load balancing based on the hash of the source and destination IP address. VMWare calls this IP-based hashing. Cisco calls this configuration Port-channeling.
At the Cisco 3020 level it looks like this:
interface Port-channel1
description ### Port channel to CORE switch ###
switchport trunk encapsulation dot1q
switchport trunk allowed vlan xxx
switchport mode trunk
link state group 1 upstream
interface GigabitEthernet0/17
description ### Link to CORE switch ###
switchport trunk encapsulation dot1q
switchport trunk allowed vlan xxx
switchport mode trunk
media-type rj45
speed 1000
channel-group 1 mode active
!
interface GigabitEthernet0/18
description ### Link to CORE switch ###
switchport trunk encapsulation dot1q
switchport trunk allowed vlan xxx
switchport mode trunk
media-type rj45
speed 1000
channel-group 1 mode active
!
interface GigabitEthernet0/19
description ### Link to CORE switch ###
switchport trunk encapsulation dot1q
switchport trunk allowed vlan xxx
switchport mode trunk
media-type rj45
speed 1000
channel-group 1 mode active
!
interface GigabitEthernet0/20
description ### Link to CORE switch ###
switchport trunk encapsulation dot1q
switchport trunk allowed vlan xxx
switchport mode trunk
media-type rj45
speed 1000
channel-group 1 mode active
Setting up a trunk, create NIC teaming in either Active/Passive or Active/Active way is not that simple and requires some good knowledge.
Hopefully VMware has some very interesting PDF documents and KB articles.
The must read are:
1- http://www.vmware.com/files/pdf/vmi_cisco_network_environment.pdf